Assignment 3: Interdomain Routing

If you made it this far it means you have proven to be highly skilled network administrator, you are promoted to campus wide network administrator. Congratulations! 

Your next assignment is to connect the campus network to the rest of the IPv6 Internet. For this you'll need to setup a BGP session with BCNET.

Router Name Uplink - IPv6 BCNET Interface - IPv6 Router ASN BCNET ASN Uplink VLAN Interface Network Prefix
Whitehorse 2607:f8f0:690:0001::2/64 2607:f8f0:690:0001::1/64 65401 65527 289 Gi-0/2.289 2607:f8f0:690:0010::/60
Vancouver 2607:f8f0:690:0002::2/64 2607:f8f0:690:0002::1/64 65402 65527 290 Gi-0/2.290 2607:f8f0:690:0020::/60
Calgary 2607:f8f0:690:0003::2/64 2607:f8f0:690:0003::1/64 65403 65527 291 Gi-0/2.291 2607:f8f0:690:0030::/60
Regina 2607:f8f0:690:0004::2/64 2607:f8f0:690:0004::1/64 65404 65527 292 Gi-0/2.292 2607:f8f0:690:0040::/60
Winnipeg 2607:f8f0:690:0005::2/64 2607:f8f0:690:0005::1/64 65405 65527 293 Gi-0/2.293 2607:f8f0:690:0050::/60
Toronto 2607:f8f0:690:0006::2/64 2607:f8f0:690:0006::1/64 65406 65527 294 Gi-0/2.294 2607:f8f0:690:0060::/60
Montreal 2607:f8f0:690:0007::2/64 2607:f8f0:690:0007::1/64 65407 65527 295 Gi-0/2.295 2607:f8f0:690:0070::/60
Halifax 2607:f8f0:690:0008::2/64 2607:f8f0:690:0008::1/64 65408 65527 296 Gi-0/2.296 2607:f8f0:690:0080::/60
  1. Configure the interface facing BCNET (GigabitEthernet0/2) with the IPv6 address specified in the table above. Make sure that the Uplink to BCNET is tagged as it's using the same interface as the Campus Links.
  2. Make sure you can ping BCNET's IPv6 address on that link.
  3. Configure an eBGP session with the BCNET router. BCNET AS number is AS65527, Your AS number is specified in the table above.
  4. Announce the prefix assigned to you to BCNET over BGP. Make sure you only announce the aggregated /60 block not the individual /64's.

 

Verify with:

  • Verify if your BGP session has been established.
  • Verify if you receive a default IPv6 route (::/0) from BCNET.
  • Verify if you can reach ipv6.google.com with ping6/traceroute6.
  • Verify if you can reach www.sixxs.net with ping6/traceroute6.
!
interface GigabitEthernet0/2.<BCNET uplink VLAN>
description BGP Uplink to BCNET
encapsulation dot1Q <BCNET uplink VLAN>
ip address <Existing Uplink IPv4 Address>
ipv6 address <Uplink IPv6 Address/64>
 
!
! -- Configure router BGP and peering with BCNET
!
router bgp <Assigned ASN>
bgp log-neighbor-changes
neighbor <BCNET Interface IPv6 Address> remote-as 65527
neighbor <BCNET Interface IPv6 Address> description BCNET IPv6 Uplink
no auto-summary
!
address-family ipv6
network <Assigned IPv6 Prefix/60>
neighbor <BCNET Interface IPv6 Address> activate
neighbor <BCNET Interface IPv6 Address> prefix-list ipv6-default in
neighbor <BCNET Interface IPv6 Address> prefix-list my-v6-net out
exit-address-family
!
! -- Define prefix-lists
!
! -- IPv6 default route prefix-list
ipv6 prefix-list ipv6-default seq 5 permit ::/0
!
! -- IPv6 prefix-list of addresses to announce
ipv6 prefix-list my-v6-net seq 5 permit <Assigned IPv6 Prefix/60>
ipv6 prefix-list my-v6-net seq 10 deny ::/0 le 128
 
!
ipv6 route <Assigned IPv6 Prefix/60> Null0 254

 

Configuration Example (Group 1):

!
interface GigabitEthernet0/2.289
description BGP Uplink to BCNET
encapsulation dot1Q 289
ip address 134.87.113.6 255.255.255.252
ipv6 address 2607:F8F0:690:1::2/64
 
!
! -- Configure router BGP and peering with BCNET
!
router bgp 65401
bgp log-neighbor-changes
neighbor 2607:F8F0:690:1::1 remote-as 65527
neighbor 2607:F8F0:690:1::1 description BCNET IPv6 Uplink
no auto-summary
!
address-family ipv6
network 2607:F8F0:690:10::/60
neighbor 2607:F8F0:690:1::1 activate
neighbor 2607:F8F0:690:1::1 prefix-list ipv6-default in
neighbor 2607:F8F0:690:1::1 prefix-list my-v6-net out
exit-address-family
!
! -- Define prefix-lists
!
! -- IPv6 default route prefix-list
ipv6 prefix-list ipv6-default seq 5 permit ::/0
!
! -- IPv6 prefix-list of addresses to announce
ipv6 prefix-list my-v6-net seq 5 permit 2607:F8F0:690:10::/60
ipv6 prefix-list my-v6-net seq 10 deny ::/0 le 128
 
!
ipv6 route 2607:F8F0:690:10::/60 Null0 254

The last statement is a static route entry for the /60 aggregate prefix. Alternatively you could achieve the same by using an aggregate statement.

 

Verify with:

  • Verify if your BGP session has been established.  Use "show bgp ipv6 unicast summary".

R2#show bgp ipv6 unicast summary

BGP router identifier 134.87.113.65, local AS number 65402
BGP table version is 3, main routing table version 3
2 network entries using 312 bytes of memory
2 path entries using 152 bytes of memory
3/2 BGP path/bestpath attribute entries using 504 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 1024 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs
 
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2607:F8F0:690:2::1
4 65527 9 12 3 0 0 00:02:24 1
  • Verify if you receive a default IPv6 route (::/0) from BCNET.
R2#show ipv6 route bgp
IPv6 Routing Table - Default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B ::/0 [20/0]
via 2607:F8F0:690:2::1
  • Verify if you can reach www.bc.net with "traceroute6".

[v6guru@client9 ~]$ traceroute6 www.bc.net
traceroute to www.bc.net (2607:f8f0:670:2::4), 30 hops max, 40 byte packets
 1  2607:f8f0:690:51::1 (2607:f8f0:690:51::1)  0.460 ms  0.403 ms  0.423 ms
 2  2607:f8f0:690:5::1 (2607:f8f0:690:5::1)  1.106 ms  1.072 ms  1.033 ms
 3  www.bc.net (2607:f8f0:670:2::4)  0.996 ms  0.958 ms  0.921 ms
  • Verify if you can reach ipv6.google.com with "ping6" and/or "traceroute6".
nestaff15:~ tobywong$ ping6 ipv6.google.com
PING6(56=40+8+8 bytes) 2607:f8f0:670::225:ff:fed4:1008 --> 2001:4860:b006::63
16 bytes from 2001:4860:b006::63, icmp_seq=0 hlim=56 time=11.208 ms
16 bytes from 2001:4860:b006::63, icmp_seq=1 hlim=56 time=11.353 ms
16 bytes from 2001:4860:b006::63, icmp_seq=2 hlim=56 time=11.418 ms
16 bytes from 2001:4860:b006::63, icmp_seq=3 hlim=56 time=11.249 ms
^C
--- ipv6.l.google.com ping6 statistics ---
4 packets transmitted, 4 packets received, 0.0% packet loss
round-trip min/avg/max/std-dev = 11.208/11.307/11.418/0.083 ms

 

useful links