Assignment 2: Campus Routing

Now that you have a working IPv6 network in your department, it's time to connect your IPv6 network to the other departments.

First you will configure IPv6 addresses on the links to the two neighbouring networks.

Once you can reach your neighbour networks over IPv6, we will enable OSPFv3 to share IPv6 routes. You will need to announce all the connected networks of your department.

At the end of this assignment you should be able to reach the VM's (NET1 & NET2) of all other departments.

The table below shows the addressing to be used for this assignment, note that all links are enabled for VLAN trunking.

Router Name Campus Link 1 - IPv6 Campus Link 1 - VLAN Interface Campus Link 2 - IPv6 Campus Link 2 - VLAN Interface
Whitehorse 2607:f8f0:690:0091::1/64 288 GigEthernet0/2.288 2607:f8f0:690:0092::1/64 281 GigEthernet0/2.281
Vancouver 2607:f8f0:690:0092::2/64 281 GigEthernet0/2.281 2607:f8f0:690:0093::1/64 282 GigEthernet0/2.282
Calgary 2607:f8f0:690:0093::2/64 282 GigEthernet0/2.282 2607:f8f0:690:0094::1/64 283 GigEthernet0/2.283
Regina 2607:f8f0:690:0094::2/64 283 GigEthernet0/2.283 2607:f8f0:690:0095::1/64 284 GigEthernet0/2.284
Winnipeg 2607:f8f0:690:0095::2/64 284 GigEthernet0/2.284 2607:f8f0:690:0096::1/64 285 GigEthernet0/2.285
Toronto 2607:f8f0:690:0096::2/64 285 GigEthernet0/2.285 2607:f8f0:690:0097::1/64 286 GigEthernet0/2.286
Montreal 2607:f8f0:690:0097::2/64 286 GigEthernet0/2.286 2607:f8f0:690:0098::1/64 287 GigEthernet0/2.287
Halifax 2607:f8f0:690:0098::2/64 287 GigEthernet0/2.287 2607:f8f0:690:0091::2/64 288 GigEthernet0/2.288

  1. Configure the IPv6 addresses on the connection towards your two neighbour networks (Campus Links 1 and 2). The IPv6 addresses and VLANs to be used are listed in the table above.
  2. Configure and enable OSPFv3 on your router, we will use area 0 and no authentication.
  3. Enable OSPF on the NET1 & NET2 interfaces (GigabitEthernet0/0 & GigabitEthernet0/1) as passive interfaces.
  4. Enable OSPF on the campus connection towards your two neighbour networks (Campus Links 1 and 2).
  5. Make sure it establishes adjacencies with both of your neighboring routers.
  6. Make sure that NET1 and NET2 prefixes are announced to your neighbour.
  7. On links like these we want IPv6 routers advertisements to be disabled. Disable router advertisement on these campus links.

 

Configuration Template

interface GigabitEthernet0/2
description Uplink to Campus switch
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/2.<Campus Link1 VLAN>
encapsulation dot1Q <Campus Link1 VLAN>
ipv6 address <Campus Link1 IPv6 Address/64>
! -- Suppress Router Advertisements
ipv6 nd ra suppress
! -- Include this interface in OSPF Area 0
ipv6 ospf 1 area 0
no cdp enable
!
interface GigabitEthernet0/2.<Campus Link2 VLAN>
encapsulation dot1Q <Campus Link2 VLAN>
ipv6 address <Campus Link2 IPv6 Address/64>
! -- Suppress Router Advertisements
ipv6 nd ra suppress
! -- Include this interface in OSPF Area 0
ipv6 ospf 1 area 0
no cdp enable
!
interface GigabitEthernet0/0
description NET1
ip address <Existing NET1 IPv4 GW Address>
duplex auto
speed auto
ipv6 address <NET1 IPv6 GW Address/64>
! -- Include this interface in OSPF Area 0
ipv6 ospf 1 area 0
!
interface GigabitEthernet0/1
description NET2
ip address <Existing NET2 IPv4 GW Address>
duplex auto
speed auto
ipv6 address <NET2 IPv6 GW Address/64>
! -- Include this interface in OSPF Area 0
ipv6 ospf 1 area 0
!
! -- Configure router OSPFv3
!
ipv6 router ospf 1
log-adjacency-changes
passive-interface GigabitEthernet0/0
passive-interface GigabitEthernet0/1
!

 

Example Configuration (Group 2):

interface GigabitEthernet0/2
description Uplink to Campus switch
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/2.281
encapsulation dot1Q 281
ipv6 address 2607:F8F0:690:92::2/64
! -- Suppress Router Advertisements
ipv6 nd ra suppress
! -- Include this interface in OSPF Area 0
ipv6 ospf 1 area 0
no cdp enable
!
interface GigabitEthernet0/2.282
encapsulation dot1Q 282
ipv6 address 2607:F8F0:690:93::1/64
! -- Suppress Router Advertisements
ipv6 nd ra suppress
! -- Include this interface in OSPF Area 0
ipv6 ospf 1 area 0
no cdp enable
!
interface GigabitEthernet0/0
description NET1
ip address 134.87.113.57 255.255.255.248
duplex auto
speed auto
ipv6 address 2607:F8F0:690:20::1/64
! -- Include this interface in OSPF Area 0
ipv6 ospf 1 area 0
!
interface GigabitEthernet0/1
description NET2
ip address 134.87.113.65 255.255.255.248
duplex auto
speed auto
ipv6 address 2607:F8F0:690:21::1/64
! -- Include this interface in OSPF Area 0
ipv6 ospf 1 area 0
!
! -- Configure router OSPFv3
!
ipv6 router ospf 1
log-adjacency-changes
passive-interface GigabitEthernet0/0
passive-interface GigabitEthernet0/1
!

 

Verify with:

  • Verify OSPF adjacencies are working by issuing "show ipv6 ospf neighbor".
R2#show ipv6 ospf neighbor
 
Neighbor ID Pri State Dead Time Interface ID Interface
134.87.113.49 1 FULL/DR 00:00:30 11 GigabitEthernet0/2.281
  • Verify your routing table to see which IPv6 prefixes you are receiving, use "show ipv6 route".
R2#show ipv6 route
IPv6 Routing Table - Default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
O 2607:F8F0:690:91::/64 [110/2]
via FE80::21F:9EFF:FE56:F368, GigabitEthernet0/2.281
C 2607:F8F0:690:92::/64 [0/0]
via FastEthernet0/0.281, directly connected
L 2607:F8F0:690:92::2/128 [0/0]
via FastEthernet0/0.281, receive
C 2607:F8F0:690:93::/64 [0/0]
via FastEthernet0/0.282, directly connected
L 2607:F8F0:690:93::1/128 [0/0]
via FastEthernet0/0.282, receive
L FF00::/8 [0/0]
via Null0, receive
  • Do a "traceroute6" to a few of the other routers / client VM's
$ traceroute6 2607:f8f0:690:12:21b:63ff:fe9a:2d3d

Here are the IPv6 Client VM IP Adresses you may want to try reaching.

Name Router ID IPv4 Address IPv6 Address
Client 1 Whitehorse 134.87.113.42 2607:f8f0:690:11:5652:ff:fe70:f501
Client 2 Whitehorse 134.87.113.50 2607:f8f0:690:12:5652:ff:fe70:f502
Client 3 Vancouver 134.87.113.58 2607:f8f0:690:21:5652:ff:fe70:f503
Client 4 Vancouver 134.87.113.66 2607:f8f0:690:22:5652:ff:fe70:f504
Client 5 Calgary 134.87.113.74 2607:f8f0:690:31:5652:ff:fe70:f505
Client 6 Calgary 134.87.113.82 2607:f8f0:690:32:5652:ff:fe70:f506
Client 7 Regina 134.87.113.90 2607:f8f0:690:41:5652:ff:fe70:f507
Client 8 Regina 134.87.113.98 2607:f8f0:690:42:5652:ff:fe70:f508
Client 9 Winnipeg 134.87.113.106 2607:f8f0:690:51:5652:ff:fe70:f509
Client 10 Winnipeg 134.87.113.114 2607:f8f0:690:52:5652:ff:fe70:f510
Client 11 Toronto 134.87.113.122 2607:f8f0:690:61:5652:ff:fe70:f511
Client 12 Toronto 134.87.113.130 2607:f8f0:690:62:5652:ff:fe70:f512
Client 13 Montreal 134.87.113.138 2607:f8f0:690:71:5652:ff:fe70:f513
Client 14 Montreal 134.87.113.146 2607:f8f0:690:72:5652:ff:fe70:f514
Client 15 Halifax 134.87.113.154 2607:f8f0:690:81:5652:ff:fe70:f515
Client 16 Halifax 134.87.113.162 2607:f8f0:690:82:5652:ff:fe70:f516